Call of Duty (COD) Warzone – Installing Shaders Bug – How to fix

COD Warzone Installing Shaders Bug fix – Experiencing the “Installing Shaders bug” in Call of Duty Warzone? Don’t worry we got you.

Call of Duty (COD) Warzone – Installing Shaders Bug – How to fix

What is the the Installing Shaders Bug in COD Warzone?

It is a bug where players are getting a message on top of their screens that says “Installing shaders to optimize performance during gameplay: In progress: Pack 1“. And different people are witnessing different variants of this bug. For some the Installing shaders to optimize performance during gameplay: In progress Pack 1 is stuck at 0% and for some the message is popping up repeatedly even after the installation has been completed once.

This is really frustrating as this hinders the gameplay experience. And if someone tries to play the game when the shaders installation is going on, the game will lag horribly for them. This bug has already been addressed by Infinity Ward many times. But it keeps coming back again and again.

How to fix this bug?

People who have already played Call of Duty Modern Warfare 2019 should know that the installing shaders bug is present in the game since the launch. It gets fixed but keeps coming back. Before the Warzone update dropped the bug was completely gone. But it came back as soon as Warzone arrived.

Now, there can be two reasons for why the installation progress is stuck at 0% for you. Either, it is really bugged or you do not have a powerful enough PC where the installation would be much faster. We tested this on two systems, one PC had a Ryzen 5 3600 and the other one had a i3 8100. And obviously the installation on the Ryzen PC was flawless and much faster.

This installation did get stuck on the i3-8100 PC and all we did was restart the game. After the restart, the installation did take some time but it was completed.

But if the message is popping up repeatedly even after you have completed the installation once then this is what you need to do:

  • Start the game
  • Go Options
  • Click on Graphics
  • Look for the option Restart Shaders Installation
  • Click on it
  • And wait for the installation to be completed
  • Restart the game once it is done

If you think this guide had helped you then let us know in the comment section below. Also, If you are facing problems that are not mentioned on this article then also you can comment below. We will try come out with a fix. Good luck!


That’s all folks!

20 thoughts on “Call of Duty (COD) Warzone – Installing Shaders Bug – How to fix”

      1. I’ve had the same issue as David where it finished but it keeps doing it. I’ve tried the restart installation option but to no avail. Do you have a link to Infinity Ward’s comment on the issue or something? Thanks in advance

  1. My call of duty modern warfare after update with warzone. When I play training in warzone after about 3 minutes my game just shuts down for no reason, no error message nothing. I even uninstalled Nvidia graphics and reinstalled. Same with COD. Nothing works it keeps doing the same thing.

    1. Stay in the menu for about 10-15 minutes before jumping into a game. I do this every time I play Warzone to avoid random crashes. Works 100% of the time.

  2. First I had Dev Error 6164 .tried to run the game again that asked me to go Safe Mod (choosed No since it will cause other errors) but after doing scan and repair in battle.net the error was gone fortunately.As for my shaders installation, it stucks at Pack 3 in 7% progress (Restarting the shaders installation from option didn’t made any difference).But not only that,when entering the lobby the guy with the gun who supposed to walk in front of screen (not the one behind it) is invisible,he’s not even there.Entering Battle Royal will result:timed out while connecting.Only Plunder mod is working but its not the end of it 😐
    after entering the map; all the textures including weapons,skins and buldings…all the detail is blurred/foggy like you’re literally playing Minecraft.And then crashed in middle of the game after 20 minutes playing…got killed and Fatal Error [5.0] ‘mp_donetsk_00056_tr.ff’
    R.I.P

    My rig:
    CPU:Intel Core i7 9700k
    RAM:16GB DDR4
    OS: Windows 10 Pro 1903
    Graphics: NVIDIA GeForce GTX 1660 6GB

    1. Aidan de la Hunt

      I am having the exact same issues as you bro, literally pack 3 stopping at 7%, only getting into plunder with graphics not rendering correctly…

  3. deepanshu sonwane

    I tried to launch the game it keeps on freezing at intro video and shaders is stuck at 5% of pack 1 even I have left it freezed at that scene for hours and relaunched it to see any progress at shaders no luck its stuck at 5% and keeps on freezing at intro video

  4. everytime i lauch the game, i get sent back to my desktop when my shaders download to 5%, like imagine a triplee AAA game having an stupid ass indie game bug that can be fixed easily…. but nope.

  5. My game crashes saying techsets_mp_br_quarry.ff while installing multiplayer shaders while my game is loading. need help

  6. I still have the shaders bug. I tried everything, reinstalling, updated drivers, anything. I launch the game and it always tries to install the shaders. I restart the game, happens again. So I guess it’s time to quit and forget about this game or what?

  7. So my problem is that it installs shaders pack 1 just fine, but when it’s finished with pack 1 it says installation complete. I know there are 3 packs, but can’t figure out how to get it to install them.

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top